If you are unable to make settings from the link you receive by email when registering, re-authenticating your account, or resetting your password, please check the following.
Possible Cause
- Link expired
- I clicked the resend button in the verification email and received two or more emails, but I accessed an old link.
- I clicked the resend button in the verification email and received two or more emails, but I accessed an old link.
Error Message Displayed
"Your request is invalid. Please check the link in your most recent email to see if you are accessing it."
How to Resolve
1. Check your spam folder
2. Send the verification email again
For password reset
Please reset your password again .
For member registration/account verification
Please access the login screen and click Resend email.
3. Access the link within the expiration date (1 hour)
If Not Resolved
Please contact our technical support with the following information.
- OS type and version
- Browser type and version
- What is happening